Plug-ins

MixEmergency has the ability to load transition and effect plug-ins. Plug-ins give you the freedom to choose which additional effects and transitions you would like to install.

Our plug-ins are in a format created exclusively for MixEmergency and use the same high-performance graphics technologies used in MixEmergency's rendering engine.

Do you have an idea for an effect or transition plug-in? Post your plug-in suggestions on our forum.

MixEmergency Featured Plug-in

Alpha Overlay

All Plug-ins

Require MixEmergency 2.3.0 or greater:

Require MixEmergency 2.0.0 or greater:

Require MixEmergency 1.4.0 or greater:

Minimum Requirements - Mac (2010 model or later) - Mac OS X 10.8.5 - Scratch Live 1.9.2 or Serato DJ 1.6