MixEmergency Support

If you require support for MixEmergency, please first check the Frequently Asked Questions page, or post on our support forum.

For further assistance:

Minimum Requirements - Mac (2010 model or later) - Mac OS X 10.8.5 - Scratch Live 1.9.2 or Serato DJ 1.6